Campus Network Connectivity Issues
Incident Report for UITS System Status
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 13:02 EST
Investigating
The campus is experiencing intermittent network connectivity issues. Please be assured that members of University Information Technology Services (UITS) are working to address these issues and expect to have the cause identified and resolved soon.

We will update you when the issue has been resolved. Thank you for your patience.
Posted Feb 12, 2024 - 11:51 EST
This incident affected: Network and Telecommunications (CSU Network).