Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2024 - 23:00 EDT
Scheduled
The University System of Georgia's Information Technology Services (ITS) team will be applying upgrades to Columbus State University's Banner environment.
During this period, the following services may be intermittently unavailable: Banner Admin Pages Banner Faculty Grade Entry Banner SIS Banner Workflow DegreeWorks My Housing Portal
During this period, the following services will be in a reduced functionality mode: MyCSU
Posted Sep 04, 2024 - 08:24 EDT
This scheduled maintenance affected: Banner and Learning Management Platforms (Banner (Student Information System), Banner Workflow, Degree Works, Banner Reports).