Some users may be unable to access their Exchange Online mailbox using Outlook on the web
Incident Report for UITS System Status
Resolved
Microsoft has confirmed that deployment of the fix has completed, and impact has been mitigated.
Posted Jun 27, 2023 - 16:31 EDT
Update
Microsoft is monitoring progress of the fix and are seeing failure rates decrease. The deployment process is accelerating and therefore we're expecting to see more significant improvement over the next 60 minutes.
Posted Jun 27, 2023 - 15:54 EDT
Monitoring
Microsoft has initiated their deployment of the fix, and users should experience incremental relief as the fix progresses. They are closely monitoring the deployment to ensure that the service recovers as expected and will provide an estimated timeline when available.
Posted Jun 27, 2023 - 15:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 27, 2023 - 15:12 EDT
Update
Affected users may encounter an unexpected 500 error when accessing Outlook on the web.

Current status: Microsoft has implemented an additional change that is showing some positive results. They are performing additional testing, which should complete within the next 60 minutes. If successful, they will immediately deploy the change to all affected infrastructure.
Posted Jun 27, 2023 - 13:22 EDT
Identified
Affected users may encounter an unexpected 500 error when accessing Outlook on the web.
Posted Jun 27, 2023 - 10:34 EDT
This incident affected: Microsoft Services (Microsoft 365).